PlanetBids - Platform Performance Degradation – Incident details

System Status

Platform Performance Degradation

Resolved
Partial outage
Started 22 days agoLasted about 8 hours

Affected

Agency Hub

Degraded performance from 12:07 PM to 6:55 PM, Operational from 6:55 PM to 8:32 PM

Vendor Portal

Degraded performance from 12:07 PM to 6:55 PM, Operational from 6:55 PM to 8:32 PM

VendorLine

Degraded performance from 12:07 PM to 6:55 PM, Operational from 6:55 PM to 8:32 PM

Updates
  • Resolved
    Resolved

    Throughout the day, we observed an unexpected increase in demand for specific public data on our platform, which caused a temporary slowdown in our service.

    Our resource monitoring system worked as planned and alerted our engineering team within minutes who quickly began investigating and implementing solutions to stabilize performance. We identified the root cause was related to a surge in requests for publicly available data. To address this, we made some immediate changes, including the addition of new optimizations to our database. While these improvements took some time to fully integrate into our system today, they have now been successfully applied.

    Moving forward, we are implementing additional measures to ensure the continued stability of our service, even during times of high demand. These enhancements include further database optimizations, increased caching, and improved monitoring. Our goal is to provide you with the best experience possible, and we are taking every step necessary to prevent similar incidents in the future.

    Your trust and satisfaction are our top priorities, and we are grateful for your patience and understanding. Should you have any questions or need additional support, please do not hesitate to reach out to our customer service team.

  • Monitoring
    Monitoring

    Our team has rolled out the database performance changes and the corresponding changes have been applied to the database. Database performance is improving. We will continue to monitor the platform.

  • Identified
    Identified

    Our team has identified database performance issues due to an unexpected increase in requests to publicly available data on our platform. We are working to apply changes to our database infrastructure to handle the additional requests.

  • Investigating
    Investigating